Error when conducting OCC Well Search

Hi, I am attempting a well search on the OCCEweb.com site. I am able to do a general search and get a listing of wells. But when I click on the small magnifying glass icon on the far left, this should give me details on that specific well. However, it doesn’t. I only get a zoomed in view of the same page. According to the publication (Basic Info for the OK Royalty Owner) AND from a phone call with someone at the OCC, this is due to my pop up blocker settings??? I have changed all settings I can possibly find for my browser to NOT block any pop-ups. I have tried using the suggested alt-control key as the publication suggests but nothing has worked. I’m using Safari, btw which works fine on all other websites. I need to get info on when a particular well was drilled. Is there any one who can help me with this particular website issue or is there anywhere else I can find when a specific well was drilled? Thanks!

Give us your legal and well name and we will get you that information.

You could also try https://imaging.occ.ok.gov/imaging/OGWellRecords.aspx It is a simpler website, but you’ll need to know the well name or API number. From 1001A is the spud report.

Sorry, I had to put this aside for a bit but I’m back at it. I have a number of wells I want to research so the link provided by PeteR is a good solution. I do appreciate your generous offer to help.

Thank you, this will work.